Also, just in case you ever do check this thread again.
This is the app I use to make sure I'm on the correct baseband.
It'll give me compatible basebands I can flash to if I'm having troubles with my current one.

https://play.google.com/store/apps/d...ure=gp_receipt

It's called GetRIL. If you're rooted you'll be able to download and flash right from the app. I hope you see this and or have already fixed the problem!